PC SOFT
DEPOT EN LIGNE
POUR WINDEVWEBDEV ET WINDEV MOBILE

Notifications Prowl
Publié par floman321
dans la catégorie Outils
Nouveautés
Description
Prowl est un service qui permet d'envoyer des notifications (message) par Internet
Ces notifications peuvent être une information, un évènement ou un rappel de rendez vous !

Des applications clientes permettent de recevoir ces notifications sur Iphone, PC et mac

Site officiel : https://prowl.weks.net/
Prowl Pc : http://www.growlforwindows.com

Exemple d'utilisation avec Windev :
Remplacer les SMS d'informations sur Iphone (envoi gratuit)
Envoyer des informations sur les mise à jours.

-----------------------------------------------------------------------------------------

SI PAS Envoyer_Notification("Windev","AnEvent"+HeureSys,"esssai "+HeureSys,"2") ALORS
Erreur(ErreurInfo)
FIN

------------------------------------------------------------------------------------------

PROCEDURE Envoyer_Notification(LOCAL Titre est chaîne,LOCAL SousTitre est chaîne,LOCAL description est chaîne,LOCAL priority est chaîne = 0)

api_key est chaîne = "arecuperer_survotrecompte"; // https://prowl.weks.net/settings.php
reponse est chaîne = ""
url est chaîne = "https://prowl.weks.net/publicapi/add"

SI HTTPRequête(url,"","","apikey="+api_key+"&application="+Titre+"&event="+SousTitre+"&description="+description+"&priority="+priority) ALORS
reponse = HTTPDonneRésultat(HTTPRésultat)

SI Position(reponse,"error") > 0 ALORS
RENVOYER Faux
SINON
RENVOYER Vrai
FIN

SINON
RENVOYER Faux
FIN

Illustrations, copies d'écran
none
none
Avis des utilisateurs
(Pour noter la ressource, cliquez sur Ecrire un avis)
Aucun avis ou commentaire ? Soyez le premier !
A PROPOS
EVALUATION :
3.2520(20)
TELECHARGEMENTS :
946
PUBLIÉE :
19 juillet 2009
VERSION :
CONCERNE :
WINDEV
Version minimale : 01F120056c
TAILLE :
143,7 Ko
DU MÊME DÉVELOPPEUR